A "8.7023: Service unable to start database" Error Occurs When Logging into a Database

July 18, 2005 | KB: 1000295
Laserfiche 6, Plus 6

Summary

When you log in, you may receive the following error message:

    8.7023: Service unable to start database

Cause

There are a number of causes for this particular error and they are listed as follows:

  1. The database (.mdf) files may not be properly attached. See Resolution 1.
  2. LaserFiche may not have the correct permissions to access the SQL database. See Resolution 2.
  3. There is a licensing issue with the LaserFiche Server. See Resolution 3.
  4. The LaserFiche for Microsoft SQL Server service is starting before the MSDE service or the Microsoft SQL Server service. See Resolution 4.
  5. MSDE is not properly installed. See Resolution 5.

Resolution 1

This issue may occur when an expansion database has not been attached to your SQL server engine. This section explains two methods (VBScript and OSQL) through which you may attach expansion databases.

To attach an expansion database using a VBScript file:

  1. Click here and here to download ListSqlDbs.vbs and AttachDb.vbs.
  2. Run ListSqlDbs.vbs by double-clicking it. This script is designed to find SQL databases with similar names.
    1. From the first LaserFiche dialog box, type ServerName\LaserFiche. The term ServerName represents the name of the computer where the SQL server resides. Click OK.

      Note: If you upgraded LaserFiche Team (Group) to LaserFiche United (Standard\Enterprise), then you should only specify the name of the computer where the SQL server resides.

    2. From the second LaserFiche dialog box, type in the name of the SQL database associated with the LaserFiche database in question. Typically, the SQL database name is the same as the LaserFiche database name. Click OK.
    3. A message box will post a list of SQL databases. Take note of all the databases that end in "_Data_n" where n stands for a sequential number.
    4. Compare what is listed to the .mdf files in the database directory.
    5. Use the following script to attach the unattached databases.
  3. Run AttachDbs.vbs by double-clicking it. This script is designed to attach SQL databases.
    1. From the first LaserFiche dialog box, type ServerName\LaserFiche. The term ServerName represents the name of the computer where the SQL server resides. Click OK.

      Note: If you upgraded LaserFiche Team (Group) to LaserFiche United (Standard\Enterprise), then you should only specify the name of the computer where the SQL server resides.

    2. From the second LaserFiche dialog box, type in the name of the SQL database that you would like to attach.
    3. Type in the full path and filename for the specified database. Click OK.
  4. Repeat step 5 as needed for any additional expansion databases.

To attach the expansion database using the OSQL command line utility:

  1. Start the OSQL utility by opening a Windows command prompt.
    1. Click Start.
    2. Select Run to load the Run dialog box.
    3. Under the "Open" option, type the following line:

      cmd

    4. Click OK.
  2. At the command prompt, type the following line:

    osql -E -S Computer Name\LaserFiche

    Note: If you upgraded LaserFiche Team (Group) to LaserFiche United (Standard\Enterprise), then you should only specify the name of the computer where the SQL server resides.

  3. Get the filenames for your databases by typing the following three lines at the OSQL prompt:

    USE master
    SELECT * FROM sysdatabases
    GO

  4. Write down the databases that are displayed.
  5. Compare what is listed to the .mdf files in the database directory.
  6. Attach each database by typing the following in the command prompt:

    EXEC sp_attach_db 'Database Name_data_1', 'C:\Path to Database Directory\Database Name_data_1.mdf'
    GO

  7. Repeat step 6 as needed for any additional expansion databases.
  8. Type EXIT to close the program.

Resolution 2

LaserFiche may not have the proper permissions to access the SQL database.

To check permissions for the LaserFiche for Microsoft SQL Server service:

  1. From the Control Panel, double-click Administrative Tools.
  2. Double-click Services.
  3. Find the LaserFiche for Microsoft SQL Server service.
  4. Find out the user account assigned to the LaserFiche Server by looking under the Log On As column.
  5. Check that the specified user has sufficient permissions to access the SQL database.
  6. To change the service to log on as the administrator:
    1. Click the LaserFiche for Microsoft SQL Server service.
    2. From the Action menu, click Properties.
    3. From the Log On tab, under "Log on as:", select "This account:".
    4. In the "This account:" field, type in administrator.
    5. Type in the appropriate password in the Password and Confirm password fields.
    6. Click OK.
    7. From the Action menu (making sure that the LaserFiche for Microsoft SQL Server service is still selected), click Restart.

Resolution 3

The licensing on your LaserFiche Server may be causing this issue. This occurs when the LaserFiche Server license has expired or when an unlicensed LaserFiche Server has been detected.

Perform one of the following:

  • If your license has expired, please contact your certified dealer to update your license.
  • If you suspect that an unlicensed copy of the LaserFiche Server is running, please contact LaserFiche Technical Support.

Resolution 4

The LaserFiche for Microsoft SQL Server service is starting before the MSDE or SQL Server service. For information on how to prevent the LaserFiche Server from starting before MSDE or SQL Server, please refer to the article listed below:

1000446 Editing the DependOnService Registry String

Resolution 5

MSDE is not properly installed. You will need to reinstall MSDE.

To reinstall MSDE:

  1. Insert the LaserFiche Client installation CD.
  2. From a file management application (i.e. Windows Explorer), explore the contents of the CD.
  3. Open the MSDE folder by double-clicking it.
  4. Run LF6Installtail.exe by double-clicking it. The MSDE installation will load.