A "6522(121): Could not log into the database. xxServerLogin Failed." Error Occurs When Publishing a Volume

March 23, 2004 | KB: 1000291
Laserfiche 6, Plus 6

Summary

When you publish a volume using the LaserFiche Plus Plug-in, you may receive the following error message:

    Could not log into the database. xxServerLogin Failed with error 6522(121).

Cause

There are a number of causes for this particular error and they are listed as follows:

  1. The Windows account in use does not have sufficient rights to the publishing directory. See Resolution 1.
  2. Publishing large volumes may cause the LaserFiche Server to time-out. See Resolution 2.
  3. MSDE is not properly installed. See Resolution 3.

Resolution 1

LaserFiche does not have the necessary permissions to access the Plus publishing directory. Make sure the LaserFiche for Microsoft SQL Server service is logged in as an administrator or as a user with sufficient rights.

To check permissions for the LaserFiche for Microsoft SQL Server service:

  1. Click Start.
  2. Click Control Panel.
  3. In Control Panel, click Administrative Tools.
  4. In Administrative Tools, click Services.
  5. In the Administrative Tools dialog box, scroll down and locate the LaserFiche for Microsoft SQL Server service.
  6. At the most right-hand column, check to see that the service is logged in as a user with sufficient permissions.

To change the log on property for a service:

  1. Click the LaserFiche for Microsoft SQL Server service.
  2. From the Action menu, click Properties.
  3. From the Log On tab, select the appropriate option and type in the required information.
  4. Click OK.
  5. Stop and restart the service.

Resolution 2

The LaserFiche Server may encounter time-out issues when publishing large volumes. Increase the amount of time LaserFiche waits before timing out.

To edit the LF.ini settings to Increase the time-out limit:

  1. From a text editor, open the LF.ini file. See the More Information section for information on the location of the LF.ini files for your operating system.
  2. Locate the [Options] section. Add or modify the following lines:

    Thunk=0
    EngineLoadWaitTime=20

  3. Locate the [System] section. Add or modify the following line:

    LFSockTimeout=600

  4. Locate the [IPDatabase] section. Add or modify the following line:

    Your_Database_Name=LaserFiche_ServerName:Port

    Note: LaserFiche_ServerName can be either the IP address or the Machine name of the LaserFiche server.

    Note: Port specifies the communications port the Client and Server use to communicate. The default setting is 1888.

Resolution 3

The MSDE install is corrupted or not installed. Reinstall MSDE from the LaserFiche Plus installation CD.

To reinstall MSDE:

  1. Insert the LaserFiche Plus installation CD.
  2. From your My Computer window, explore the CD.
  3. Double-click to open the MSDE folder.
  4. Double-click LF6InstallTail.exe to install MSDE.

More Information

For information on where to locate the LF.ini files, click the article below:

100162 Finding the LF.ini File