A "6525: IP Connection Failed." Error Occurs When Trying to Open a Database

December 16, 2005 | KB: 1000233
Laserfiche 6, Plus 6

Summary

When you try to access the database, you may receive the following error message:

    6525: IP Connection failed

Cause

The Laserfiche client cannot communicate with the Laserfiche Server. There are a number of causes for this particular error and they are listed as follows:

  1. The Laserfiche for Microsoft SQL Server service may not be running. See Resolution 1.
  2. An incorrect Laserfiche configuration is causing the application to look at the wrong IP address. See Resolution 2.
  3. There may be a firewall between the Laserfiche Server and the Laserfiche client blocking communication. See Resolution 3.

Resolution 1

Use the Services administrative tool to start the LaserFiche for Microsoft SQL Server service.

To check that the LaserFiche for Microsoft SQL Server service is running:

  1. Click Start and then select Control Panel.
  2. From the Control Panel, double-click on Administrative Tools.
  3. From Administrative Tools, double-click on Services.
  4. Find the LaserFiche for Microsoft SQL Server service.
  5. Under the Status column, make sure that the service is "Started." If the LaserFiche for Microsoft SQL Server service is not started, please start it now.

To start the LaserFiche for Microsoft SQL Server service:

  1. From the Services dialog box, select the LaserFiche for Microsoft SQL Server service.
  2. From the Action menu, click Start.

Resolution 2

The LF.ini file is incorrectly configured. Edit the LF.ini file to point LaserFiche at the correct server.

To edit the LF.ini database connection settings:

  1. From a text editor, open the LF.ini file. See the More Information section for information on the location of the LF.ini file for your operating system.
  2. Under the [IPDatabase] section, look for the name of your database. Check to see that the database is pointing to the correct server machine name or IP address. For example:

    My_LaserFiche_Database=LaserFiche_Server_Computer_Name

      or

    My_LaserFiche_Database=255.255.255.255

    The machine name or IP address must match that of the LaserFiche Server.

Resolution 3

A firewall is blocking communication between the Laserfiche Server and the Laserfiche client. Perform one of the following:

  • Disable the firewall.
  • Modify your firewall configuration so that the communications port used by Laserfiche is open. By default, Laserfiche 6 uses port 1888.

    Note: Laserfiche can be configured to use a different port by editing the Laserfiche Server's LFS.ini file.

More Information

For information on where to locate the LF.ini files, see the following Laserfiche Knowledge Base article:

10 0162 Finding the LF.ini File

For information on changing the port used by Laserfiche, see the following Laserfiche Knowledge Base article:

1000230 A "0183: Cannot create a new file when that file already exists." Error Occurs When Starting the LaserFiche Server.